Back to overview
Resolved

Past Hotel/Cruise Stay Submissions Unavailable

Jul 14, 2026 at 2:04am UTC
Affected services
[Production] Meridian API

Resolved
Jul 14, 2026 at 2:15am UTC

Past Hotel/Cruise Stay Submissions are now visible in the dashboard. Issue has been resolved

Created
Jul 14, 2026 at 2:04am UTC

The past Hotel/Cruise Stay Submissions were not loading. The issue was investigated and a fix has been deployed.